Techfortesco server back online soon 8


UPDATE: All working now! Well done Adrian and the Tesco Labs engineering team.

https://secure.techfortesco.com/tescoapiweb/login.aspx

Hello if you’ve reached this blog when you thought you were going to techfortesco.com’s API server.

It’s OK, my lovely ex-colleagues at Tesco Labs are sorting out a new server to host the API and it will be back online shortly. You won’t have to do anything, it should all work just as it did before.

Please be patient with them.

Cheers
Nick

  • Scott Baker

    Hi Nick,

    Thanks for the update, do you have a specific time/date estimate for when it will be coming back online?

    Kind Regards,

    Scott

    • nick

      Hi Scott

      It’s likely to be after this weekend at the moment. The ‘virtual hard disk’ used by the old (and soon the new) server is of considerable size and has to be transferred under tight security and high encryption for privacy reasons, as well as uploaded into the new Azure cloud. These things always take longer than one expects, unfortunately.

      However doing it the right way is the only way. (That must be a quote from someone!).

      Cheers
      Nick

      • Trevor

        Do you have an update on when the service will resume?

        • nick

          No news yet Trevor; these things always take longer than expected.

      • Scott

        Looks like the server is back up and running (to an extent). I get a response but it’s just a variety of internal server errors. Hopefully will be fully functional soon.

  • nick

    All working now! See up date to post above
    Nick

  • Nithin

    Hi,

    I noticed that the api is back up but I am having issues trying to login.

    When I use the following command (replacing the bits with my developer key and application key) :
    https://secure.techfortesco.com/tescolabsapi/restservice.aspx?command=LOGIN&email=&password=&developerkey=&applicationkey=

    I get this error and can’t seem to access the api. It worked fine before the servers went down temporarily:
    { “StatusCode”: 200, “StatusInfo”: “Tesco.com – Signin or Register” }

    Not sure how to deal with this issue.

    Thanks,
    Nithin

  • Mark

    Hi Nick
    Hopefully you can pass this message on. Since the upgrade, it seems that you can no longer login using the anonymous logon as before. Also you can no longer do a product search using the barcode. Cheers